<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rYbxZe1rgBfrpr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"kplc"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "kplc/web/sports/nfl/final-play",
    "authors": [
                  
                    {
                      "_id": "chris-hagan",
                      "name": "Chris Hagan",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2019/05/06/brees-is-ready-re-establish-saints-identity/",
    "contentId": "POG7WR4G3FED7BRDANMETEYKP4",
    "contentName": "Brees is ready to re-establish the Saints identity for the upcoming season",
    "contentOwner": "wvue",
    "contentTags":  [
                  
                ],
    "contentType": "story",
    "datePublished": "2019-05-06T15:55:05.071Z",
    "description": "Saints start OTA's on May 21st",
    "distributorCategory": "staff",
    "distributorMode": "reference_denormalized",
    "distributorName": "Gray TV Stations",
    "distributorReferenceId": "dee592ee-659e-4038-a289-0bfe818887ca",
    "distributorSubCategory": "gray-original-content",
    "hasVideo": "false",
    "metaDescription": "Saints start OTA's on May 21st",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "Final Play",
                            "_id": "/sports/nfl/final-play",
                            "path": "/sports/nfl/final-play",
                          }
                        
                      ,
    "publishedDay": "06",
    "publishedMonth": "05",
    "publishedYear": "2019",
    "stationName": "kplc",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="k2k00ABXD6ssT0aA9jSLcfEt6XTbAVdVQupaocyxkH8"/> <title>Brees is ready to re-establish the Saints identity for the upcoming season</title> <meta name="date" content="2019-05-06T15:54:43.477Z"/> <meta itemprop="description" name="description" content="Saints start OTA's on May 21st"/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.kplctv.com/2019/05/06/brees-is-ready-re-establish-saints-identity/"> <meta name="twitter:title" content="Brees is ready to re-establish the Saints identity for the upcoming season"/> <meta name="twitter:image" content="https://www.kplctv.com/resizer/rCp0K0bIVasV8Fen7RhusmUKsFw=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CSVJVC6UKBCBBDNDIPUJBU7MZE.jpg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="Saints start OTA's on May 21st"/> <meta name="twitter:site" content="@KPLC7News"/> <meta name="twitter:creator" content="@KPLC7News"> <meta property="og:url" content="https://www.kplctv.com/2019/05/06/brees-is-ready-re-establish-saints-identity/"/> <meta property="og:title" content="Brees is ready to re-establish the Saints identity for the upcoming season"/> <meta itemprop="image" property="og:image" content="https://www.kplctv.com/resizer/rCp0K0bIVasV8Fen7RhusmUKsFw=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CSVJVC6UKBCBBDNDIPUJBU7MZE.jpg"/> <meta property="og:description" content="Saints start OTA's on May 21st"/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.kplctv.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="354227664672005"/> <meta property="fb:pages" content="99603912791"/> <meta property="fb:admins" content="644426401"/> <meta property="article:publisher" content="https://www.facebook.com/kplc7news"> <link rel="amphtml" href="/2019/05/06/brees-is-ready-re-establish-saints-identity/?outputType=amp"> <meta name="author" content="Chris Hagan"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Brees is ready to re-establish the Saints identity for the upcoming season",
        
        "image": {
          "@type": "ImageObject",
          "url": "https://www.kplctv.com/resizer/rCp0K0bIVasV8Fen7RhusmUKsFw=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CSVJVC6UKBCBBDNDIPUJBU7MZE.jpg",
          "height": 1080.0,
          "width": 1200
        },
        
        "datePublished": "2019-05-07T03:57:05.345Z",
        "dateModified": "2019-05-06T15:54:43.477Z",
        "articleBody": "NEW ORLEANS (WVUE) - The draft is obviously a huge part of the off-season, but at the end of the day, it&#039;s just complementary to what a team already has on their roster and what they&#039;ve done in free agency.That’s why for the Saints it was about drafting quality that can immediately help the team, rather than quantity at positions that are already spoken for. Their aggressive philosophy this year landed the Black and Gold center Erik McCoy, who Drew Brees believes should fit in nicely on the field and in the locker room, based how well they’ve drafted in recent years as well.“What our organization always does a great job of is really identifying our needs, and also who they feel are the best players in the draft. Guys that not only have the talent to play at the next level, but they feel like are the type of guys that we want. Possess the type of character, have the type of intelligence and toughness. Just all of the traits that we’re looking for,” said Brees.McCoy, by way of the tape and many draft grades, fits those qualities. Quite frankly though, it’s a lot of pressure. The Saints need him to live up to his billing as a guy that can start right away. The offensive line has been key to their success over the last two seasons, and they don’t want to take a step back in the absence of retired center Max Unger, who Brees says he’ll miss playing with.“He’s such a warrior, and I think for him, just like for all of us, your mindset is, ‘I don’t want to let the team down. I’ve got to be there for them.’ I think that’s what’s pushed him through now. He’s battle through a lot of stuff injury wise over the last two years. I think there comes a time for all of us. Everybody likes to leave on their own terms. I think he just felt like it was time,” said Brees.He’s not the only one they’ll have to replace in a leadership role. It can’t be underestimated how much of a catalyst Mark Ingram was for the offense, especially with his angry running style.But moving on, they have Latavius Murray to compliment Alvin Kamara is simply part of the business.“Look at free agency and the draft for everybody. Everybody re-tools. Everybody gets stronger. Everybody kind of goes back to square one. You’ve got to re-establish your identity each and every year. That’s why it’s important to have great leadership in the locker room and guys that will help drive and motivate and reinforce all of the positive things and culture of our team in our locker room throughout the off-season. To make sure we’re poised and ready to make a run at it throughout the regular season,” said Brees.Because once again, the Saints will begin this season following heartbreak from their previous playoff run. We’ll see if it takes its toll on them, having been so close to their ultimate goal two years in a row, and having it taken away in the final moments.“Maybe you never get over something like that. But bottom line is you have to somehow, some way, turn that into good. So you have to believe that even through the adversity, even through the tough times, even through the failures that don’t go your way. You’ve got to believe that God has a higher plan. It’s meant to strengthen us in some way. There will be positive that comes from it,” said Brees.Copyright 2019 WVUE. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Chris Hagan"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "",
        "logo": {
          "@type": "ImageObject",
          "url": "http://www./pb/resources/images//logo_meta.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "Saints start OTA's on May 21st"
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "",
        "url": "https://www.kplctv.com",
        "logo": "https://www.kplctv.com/pb/resources/images/rm_icons/kplc-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/kplc7news" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/9d2d5ec0dfd60b305d13/rm/rm-framework9d2d5ec0dfd60b305d13.css?v=59" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/kplc-logo.svg?v=59)}</style> <link href="/pb/resources/dist/9d2d5ec0dfd60b305d13/rm/rm-framework9d2d5ec0dfd60b305d13.css?v=59" rel="stylesheet"/> <link href="/pb/resources/dist/9d2d5ec0dfd60b305d13/rm/rm-features9d2d5ec0dfd60b305d13.css?v=59" rel="stylesheet"/> <link href="/pb/resources/dist/9d2d5ec0dfd60b305d13/rm/rm-services9d2d5ec0dfd60b305d13.css?v=59" rel="stylesheet"/> <script src="/pb/gr/c/default/rYbxZe1rgBfrpr/arcAdsJS/cdbd7d78da.js?v=59"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="fyU8pd2rgBfrpr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://kplc.incentrev.com/category/local" class="color-grey-dark">50/50 Thursdays</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kplctv.com/community/restaurant-guide/" class="color-grey-dark">Coca Cola Restaurant Guide</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://kplcconnections.revrocket.us/" class="color-grey-dark">Connections</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kplctv.com/community/the-pledge-of-allegiance/" class="color-grey-dark">The Pledge</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.kplctv.com/business/legal/legal-brief/" class="color-grey-dark">Legal Brief</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="fQthYQ1rgBfrpr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0yaZNirgBfrpr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.kplctv.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/traffic" class="">Traffic</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news/crime" class="">Crime</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/health" class="">Health</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/politics/elections" class="">Elections</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/contests" class="">Contests</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/community" class="">Community</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.kplctv.com/programming/schedule" class="">TV</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About Us</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.cwtv.com/" class="">CW</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/homepage" class="color-white">Home</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kplctv.com/live" class="color-white">Watch Live</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/news/black-history-month" class="color-white">Black History Month</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.kplctv.com/apps/" class="color-white">Download Apps</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news" class="color-white">News</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/news/national" class="color-white">National</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/news/crime" class="color-white">Crime</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/editorial" class="color-white">Consider This</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/news/hometown-heroes" class="color-white">Hometown Heroes</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/business/legal" class="color-white">Legal Corner</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="http://www.kplctv.com/2018/12/11/felix-vail/" class="color-white">Vail of Silence</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/weather" class="color-white">Weather</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/weather/cams" class="color-white">Skycams</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.kplctv.com/weather/weather-with-ben" class="color-white">Weather with Ben</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/2019/01/03/river-stages/" class="color-white">Latest River Stages</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/weather/education/" class="color-white">Weather-U</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="http://www.kplctv.com/weather/marine-forecast/" class="color-white">Marine Forecast</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="http://www.kplctv.com/weather/fishing-forecast" class="color-white">Fishing & Hunting Forecast</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/weather/hurricane" class="color-white">Hurricane Center</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/sports" class="color-white">Sports</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/sports/athlete" class="color-white">Sports Person of the Week</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/sports/high-school" class="color-white">High School</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/sports/high-school/football" class="color-white">Football</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/sports/ncaa/lsu" class="color-white">LSU</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/sports/ncaa/mcneese-state" class="color-white">McNeese State</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/traffic" class="color-white">Traffic</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kplctv.com/traffic/gas-prices/" class="color-white">KPLC Gas Price Tracker</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/health" class="color-white">Health</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kplctv.com/health/pediatric-checklist/" class="color-white">Pediatric Checklist</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/community" class="color-white">Community</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kplctv.com/2019/02/15/kplcs-crawfish-price-check/" class="color-white">Crawfish Price Check</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.kplctv.com/2018/09/10/adulting/" class="color-white">Adulting 101</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.kplctv.com/2018/09/24/babies/" class="color-white">Babies 101</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="http://www.kplctv.com/community/restaurant-guide/" class="color-white">CocaCola Restaurant Guide</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/community/calendar" class="color-white">Community Calendar</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/contests" class="color-white">Contests</a> </h3> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/programming" class="color-white">TV</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.kplctv.com/programming/schedule/" class="color-white">TV Listings</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/about-us" class="color-white">About Us</a> </h3> </li> </ul> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0CPOEdrgBfrpr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-kplc-breaking/" data-url="/pb/api/v2/render/feature" data-website="kplc" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="f0OlITkrgBfrpr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/kplc-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="kplc"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fbVIlG1rgBfrpr"> <div id="ad775-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad775" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad775",slotName:"kplc/web/sports/nfl/final-play",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"POG7WR4G3FED7BRDANMETEYKP4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="fvowwg1rgBfrpr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Brees is ready to re-establish the Saints identity for the upcoming season</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="Brees is ready to re-establish the Saints identity for the upcoming season" src="https://www.kplctv.com/resizer/lqQvKa6v2mN9IBKRdyE4MUbv2Nc=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CSVJVC6UKBCBBDNDIPUJBU7MZE.jpg"/> </div> <div class="container"> <figcaption class="caption-text spaced flex-container-row justify-space-between card card-article"> Drew Brees leaps over the line for a touchdown against the Bucs in the 2018 season. (Source: Nola.com) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0xfzpRrgBfrpr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share flex-container-column text-align-right"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Brees+is+ready+to+re-establish+the+Saints+identity+for+the+upcoming+season&amp;url=https%3A%2F%2Fwww.kplctv.com%2F2019%2F05%2F07%2Fbrees-is-ready-re-establish-saints-identity-upcoming-season%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter icon-light"></i> </button> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.kplctv.com%2F2019%2F05%2F07%2Fbrees-is-ready-re-establish-saints-identity-upcoming-season%2F&amp;title=Brees+is+ready+to+re-establish+the+Saints+identity+for+the+upcoming+season', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square icon-light"></i> </button> <a href="mailto:?subject=Brees%20is%20ready%20to%20re-establish%20the%20Saints%20identity%20for%20the%20upcoming%20season&amp;body=Read%20more%20on%20Brees%20is%20ready%20to%20re-establish%20the%20Saints%20identity%20for%20the%20upcoming%20season%20at%20https%3A%2F%2Fwww.kplctv.com%2F2019%2F05%2F07%2Fbrees-is-ready-re-establish-saints-identity-upcoming-season%2F"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <i class="far fa-envelope icon-light"></i> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f7wERX1rgBfrpr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/chris-hagan/"> <span class="font-bold ">Chris Hagan</span></a> <span class="font-bold">|</span> <span class="timestamp"> May 6, 2019 at 10:55 AM CDT - Updated May 6 at 10:57 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0fHmlKrgBfrpr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>NEW ORLEANS (WVUE) - The draft is obviously a huge part of the off-season, but at the end of the day, it's just complementary to what a team already has on their roster and what they've done in free agency.</p> </div> </div> <div data-type="raw_html" class="card collection-item card-embedded-content"> <div class="card-content card-article"> <div class="element element-rawhtml "> <iframe style="border: none" src="//html5-player.libsyn.com/embed/episode/id/9676607/height/90/theme/custom/thumbnail/yes/direction/backward/render-playlist/no/custom-color/87A93A/" height="90" width="100%" scrolling="no" allowfullscreen webkitallowfullscreen="" mozallowfullscreen="" oallowfullscreen="" msallowfullscreen=""></iframe></div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>That’s why for the Saints it was about drafting quality that can immediately help the team, rather than quantity at positions that are already spoken for. Their aggressive philosophy this year landed the Black and Gold center Erik McCoy, who Drew Brees believes should fit in nicely on the field and in the locker room, based how well they’ve drafted in recent years as well.</p> </div> </div> <div data-type="video" class="card card-captioned collection-item card-embedded-content hidden"> <div class="card-content card-article"> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“What our organization always does a great job of is really identifying our needs, and also who they feel are the best players in the draft. Guys that not only have the talent to play at the next level, but they feel like are the type of guys that we want. Possess the type of character, have the type of intelligence and toughness. Just all of the traits that we’re looking for,” said Brees.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>McCoy, by way of the tape and many draft grades, fits those qualities. Quite frankly though, it’s a lot of pressure. The Saints need him to live up to his billing as a guy that can start right away. The offensive line has been key to their success over the last two seasons, and they don’t want to take a step back in the absence of retired center Max Unger, who Brees says he’ll miss playing with.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1143-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1143" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1143",slotName:"kplc/web/sports/nfl/final-play/POG7WR4G3FED7BRDANMETEYKP4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“He’s such a warrior, and I think for him, just like for all of us, your mindset is, ‘I don’t want to let the team down. I’ve got to be there for them.’ I think that’s what’s pushed him through now. He’s battle through a lot of stuff injury wise over the last two years. I think there comes a time for all of us. Everybody likes to leave on their own terms. I think he just felt like it was time,” said Brees.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>He’s not the only one they’ll have to replace in a leadership role. It can’t be underestimated how much of a catalyst Mark Ingram was for the offense, especially with his angry running style.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>But moving on, they have Latavius Murray to compliment Alvin Kamara is simply part of the business.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad1645-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1645" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1645",slotName:"kplc/web/sports/nfl/final-play/POG7WR4G3FED7BRDANMETEYKP4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Look at free agency and the draft for everybody. Everybody re-tools. Everybody gets stronger. Everybody kind of goes back to square one. You’ve got to re-establish your identity each and every year. That’s why it’s important to have great leadership in the locker room and guys that will help drive and motivate and reinforce all of the positive things and culture of our team in our locker room throughout the off-season. To make sure we’re poised and ready to make a run at it throughout the regular season,” said Brees.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1814-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1814" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1814",slotName:"kplc/web/sports/nfl/final-play/POG7WR4G3FED7BRDANMETEYKP4",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Because once again, the Saints will begin this season following heartbreak from their previous playoff run. We’ll see if it takes its toll on them, having been so close to their ultimate goal two years in a row, and having it taken away in the final moments.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Maybe you never get over something like that. But bottom line is you have to somehow, some way, turn that into good. So you have to believe that even through the adversity, even through the tough times, even through the failures that don’t go your way. You’ve got to believe that God has a higher plan. It’s meant to strengthen us in some way. There will be positive that comes from it,” said Brees.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2019 WVUE. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f0sHfknrgBfrpr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.kplctv.com/2019/05/06/brees-is-ready-re-establish-saints-identity/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.kplctv.com/2019/05/06/brees-is-ready-re-establish-saints-identity/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="f0GazZIrgBfrpr"> <div id="ad568-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad568" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad568",slotName:"kplc/web/sports/nfl/final-play",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"POG7WR4G3FED7BRDANMETEYKP4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="fqT2RQ1rgBfrpr"> <div class="invisible weather-gradient flex-grid color-white pb-weather night" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="night-clear" data-default-location-code="USLA0264" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="kplc" data-location-code="USLA0264" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USLA0264,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.kplctv.com/weather"> <img class="radar-image" src="https://webpubcontent.raycommedia.com/kplc/weather/ESP%20NEW_thumb.JPG" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="74" data-temp-c="23"> 74</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/97_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Lake Charles, LA</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.kplctv.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="f1459Z1rgBfrpr"> <div class="article-author-bio"> <div class="article-author-bio flex-grid flex-feature"> <h3 class="bold uppercase"> <span class="rectangle"></span> Author </h3> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Chris Hagan" data-src="https://www.kplctv.com/resizer/fGWItk58km7EKjz4VyTGhExqBts=/1400x0/s3.amazonaws.com/arc-authors/raycom/fb9531da-b223-439e-910f-0bb46c8857aa.png" src="https://www.kplctv.com/resizer/I3N6UJP4IMVNELKScuTs4fKrkog=/0x10/s3.amazonaws.com/arc-authors/raycom/fb9531da-b223-439e-910f-0bb46c8857aa.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/chris-hagan/"> <h3 class="promo-header">Chris Hagan</h3> </a> <h4 class="hidden font-normal color-grey-dark"></h4> <h4 class="hidden font-normal color-grey-dark"></h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-xs"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://twitter.com/chrishagantv" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://www.facebook.com/chagantv" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:CHagan@Fox8Live.com?subject=Brees%20is%20ready%20to%20re-establish%20the%20Saints%20identity%20for%20the%20upcoming%20season&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">Chris is living a dream come true with the Fox 8 Sports team in New Orleans. As a Slidell native and Slidell High School alum, he grew up on the highs and lows of Saints and LSU football.</p> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0gvtRFrgBfrpr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fxdNcc2rgBfrpr"> <div class="flex-feature height-full"> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-16447" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/05/07/saints-announce-signing-four-undrafted-free-agents/"> <img class="width-full " alt="Saints announce signing of four undrafted free agents" src="https://www.kplctv.com/resizer/3Vph6uBdolxXOCxmTm8PV_EnodU=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/OZMQTMA4ARCOTEXY5IJH7VBZ5A.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/05/07/saints-announce-signing-four-undrafted-free-agents/"> Saints announce signing of four undrafted free agents</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Saints add four undrafted free agents</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Sean Fazende</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/05/04/don-dixon-alan-heisser-host-th-annual-cops-jocks-golf-tournament/"> <img class="width-full " alt="Don Dixon, Alan Heisser host 17th annual Cops &amp; Jocks golf tournament" src="https://www.kplctv.com/resizer/AgkSix94PgzI4UROHlLGWkb-cL8=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/AIFH4DBO7FHCHAGWOQUV2BR3MQ.png"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/05/04/don-dixon-alan-heisser-host-th-annual-cops-jocks-golf-tournament/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Don Dixon, Alan Heisser host 17th annual Cops &amp; Jocks golf tournament</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Former police chief Don Dixon and Alan Heisser hosted the 17th annual Cops and Jocks golf tournament at L'Auberge golf course on Friday afternoon.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Gabe McDonald</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fM1xEW1rgBfrpr"> <div id="ad14-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad14" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad14",slotName:"kplc/web/sports/nfl/final-play",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"POG7WR4G3FED7BRDANMETEYKP4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="cRAakN1rgBfrpr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fawiMR1rgBfrpr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-163596" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/05/03/dome-officials-outline-million-improvement-package-early-stages/"> <img class="width-full " alt="Dome officials outline $400 million improvement package in early stages" src="https://www.kplctv.com/resizer/q98-ItvCP82_fHTA8lKMp9rEpZY=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/RTOYXAPWOVFPXAJ4SQ7JAEOIQE.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/05/03/dome-officials-outline-million-improvement-package-early-stages/"> Dome officials outline $400 million improvement package in early stages</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Rob Masson</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published May 2, 2019 at 5:03 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/05/02/report-saints-decline-pick-up-th-year-option-cb-eli-apples-contract/"> <img class="width-full " alt="Report: Saints decline to pick up 5th-year option on CB Eli Apple’s contract" src="https://www.kplctv.com/resizer/VeJSKK46NCKkLyZa7E08wSo-J1g=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DPEJLEMUXRAGDEXRX24IVELRKA.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/05/02/report-saints-decline-pick-up-th-year-option-cb-eli-apples-contract/"> Report: Saints decline to pick up 5th-year option on CB Eli Apple’s contract</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Sean Fazende</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published May 1, 2019 at 7:46 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/05/01/brees-saints-draft-picks-im-excited-get-into-practice-few-weeks-see-what-weve-got/"> <img class="width-full " alt="Brees on the Saints 2019 draft picks: ‘I’m excited to get into practice in a few weeks, and see what we’ve got’" src="https://www.kplctv.com/resizer/idObNXrGGcMup83TS9aEDdz8hPU=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/VLWGIVCDSNE63LATPZBGBYZ2KY.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/05/01/brees-saints-draft-picks-im-excited-get-into-practice-few-weeks-see-what-weve-got/"> Brees on the Saints 2019 draft picks: ‘I’m excited to get into practice in a few weeks, and see what we’ve got’</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Garland Gillen</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published May 1, 2019 at 11:38 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/04/29/video-lufkins-erik-mccoy-proposes-girlfriend-following-nfl-draft-pick/"> <img class="width-full " alt="VIDEO: Lufkin’s Erik McCoy proposes to girlfriend following NFL draft pick" src="https://www.kplctv.com/resizer/Dtes9Nv0g4pRfS8sz1xKKylCrqk=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/Z2IHFVEP7VDRRBDBV2GU7WGGHQ.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/04/29/video-lufkins-erik-mccoy-proposes-girlfriend-following-nfl-draft-pick/"> VIDEO: Lufkin’s Erik McCoy proposes to girlfriend following NFL draft pick</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Caleb Beames&nbsp;and</span></span> <span><span>Dorothy Sedovic</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published April 29, 2019 at 11:47 AM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="ff6yhl2rgBfrpr"> <div id="ad559-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad559" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad559",slotName:"kplc/web/sports/nfl/final-play",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"POG7WR4G3FED7BRDANMETEYKP4"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="f09PhL6rgBfrpr"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.kplctv.com"> <div class="logo logo-slim"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 320 Division Street<br/>Lake Charles, LA 70601/70602<br/>(337) 439-9071 </p> <a class="call-to-action uppercase color-white" href="http://www.kplctv.com/about-us">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/kplc" class="color-white">FCC Public File</a></li> <li><a href="mailto:bcourtney@kplctv.com" class="color-white">bcourtney@kplctv.com <br/> (337) 437-7508</a></li> <li><a href="http://webpubcontent.raycommedia.com/kplc/docs/KPLC2018EEO.pdf" class="color-white">EEO</a></li> <li><a href="http://www.kplctv.com/story/12173010/how-to-file-a-closed-captioning-complaint/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KPLC Careers</a></li> <li><a href="http://www.kplctv.com/2018/08/24/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.kplctv.com/2018/08/24/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/KPLC7News" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/kplc7news" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/kplc" class="color-white">FCC Public File</a></li> <li><a href="mailto:bcourtney@kplctv.com" class="color-white">bcourtney@kplctv.com <br/> (337) 437-7508</a></li> <li><a href="http://webpubcontent.raycommedia.com/kplc/docs/KPLC2018EEO.pdf" class="color-white">EEO</a></li> <li><a href="http://www.kplctv.com/story/12173010/how-to-file-a-closed-captioning-complaint/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">KPLC Careers</a></li> <li><a href="http://www.kplctv.com/2018/08/24/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.kplctv.com/2018/08/24/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/KPLC7News" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/kplc7news" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rYbxZe1rgBfrpr/render.js?v=59'></script> <script async src="/pb/resources/dist/9d2d5ec0dfd60b305d13/rm/rm-index9d2d5ec0dfd60b305d13.js"></script>