<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9l5ly8e" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9l5ly8e";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Mold discovered in Sulphur's Central Fire Station - KPLC 7 News, Lake Charles, Louisiana</title>
<meta name="Description" content="Taxpayers in Sulphur may soon be reaching into their pockets to either repair or replace one of their local fire stations - all because of mold. "><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2017/02/24"><meta name="owner" content="KPLC"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="Container-E.98"><meta name="wn-base" content="IIS31"><meta name="wnreadableurl" content="mold-discovered-in-sulphurs-central-fire-station"><meta property="og:title" content="Mold discovered in Sulphur's Central Fire Station"><meta property="og:type" content="article"><meta property="og:url" content="http://www.kplctv.com/story/34602501/mold-discovered-in-sulphurs-central-fire-station"><meta property="og:image" content="http://kplc.images.worldnow.com/images/13218555_G.jpg"><meta property="og:description" content="Taxpayers in Sulphur may soon be reaching into their pockets to either repair or replace one of their local fire stations - all because of mold. "><link rel="canonical" href="http://www.kplctv.com/story/34602501/mold-discovered-in-sulphurs-central-fire-station"><meta name="author" content="Maranda Whittington"><meta name="twitter:creator" content="https://twitter.com/MarandaKPLC"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Mold discovered in Sulphur's Central Fire Station"><meta name="twitter:description" content="Taxpayers in Sulphur may soon be reaching into their pockets to either repair or replace one of their local fire stations - all because of mold. "><meta name="twitter:image" content="http://kplc.images.worldnow.com/images/13218555_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta property="fb:app_id" content="354227664672005"/><link rel="image_src" href="http://kplc.images.worldnow.com/images/1828434_G.gif"/ ><meta property="fb:admins" content="644426401" /><meta property='article:publisher' content='http://www.facebook.com/kplc7news' /><meta property="twitter:account_id" content="20445524" /><meta name="twitter:site" content="@KPLC7News" /><meta name="twitter:creator" content="@KPLC7News" /><meta name="google-site-verification" content="k2k00ABXD6ssT0aA9jSLcfEt6XTbAVdVQupaocyxkH8" /><!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=Container-E.98_7.3.9.93">
<link type="text/css" rel="stylesheet" media="all" href="http://kplc.images.worldnow.com/interface/css/container-e.css?ver=2017-05-26%2014%3A11%3A03_7.3.9.93">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.3.9.93_Container-E.98" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=Container-E.98"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=Container-E.98"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=Container-E.98"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu66 UL
                    , #menu66 .wnHorizontal { background-color: #015aca; font-family: Arial; font-size: 12px; font-weight: 700; color: #ffffff; }
                #menu66 A,
                    #menu66 LI.wnOn .wnSublevel A,
                    #menu66 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 12px; font-weight: 700; color: #ffffff; }
                #menu66 .wnHorizontal .wnDynamic .wnMenuTypeText
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { padding-right: 15px; }
                #menu66
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { background: url('http://kplc.images.worldnow.com/images/static/gfx/nav_tridown.gif') no-repeat 98% 50%; }
                #menu66
                        .wnLevel1 LI.wnHasSublevel .wnLevel2 .wnMiddle SPAN { background: none; }
            #menu66 UL LI.wnOn { background-color: #015aca; color: #ffffff; }
                    #menu66 LI.wnOn A,
                        #menu66 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu66 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #ffffff; }
                    #menu66 .wnSublevel { background-color: #015aca;  }
                #menu66 .wnSublevel A { border : 1px #015aca solid; border-top: none; }
                        #menu66 .wnSublevel .wnFirstNode { border-top : 1px #015aca solid; }
                        #menu66 .wnHorizontal .wnDynamic .wnMenuTypeText .wnSublevel LI.wnHasSublevel A { padding-right: 9px; }
                #menu66 .wnSublevel LI.wnHasSublevel A { background: url('http://kplc.images.worldnow.com/images/static/gfx/nav_tri.gif') no-repeat 98% 50%; }
                #menu66 .wnSublevel LI.wnHasSublevel .wnLevel3 A { background: none; }
            #menu66 .wnSublevel LI.wnOn { background-color: #015aca;  }
                    #menu66 .wnRight .wnMiddle { background: url('http://kplc.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu66 LI.wnOn .wnMiddle { background-image: url('http://kplc.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'KPLC',
            affiliateId : '66',
            baseUrl : 'www.kplctv.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.3.9.93',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '162',mdPartnerDomain : 'http://dub.kplctv.com'},
            registrationId : '104054',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://kplc.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='Container-E.98';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='KPLC';
wng_pageInfo.ownerAffiliateId=parseInt('66',10);
wng_pageInfo.containerId=parseInt('34602501',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='News';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/34602501/mold-discovered-in-sulphurs-central-fire-station';
wng_pageInfo.content_authors='Maranda Whittington';
wng_pageInfo.headline='Mold discovered in Sulphur\'s Central Fire Station';
wng_pageInfo.pageTitle='Mold discovered in Sulphur\'s Central Fire Station - KPLC 7 News, Lake Charles, Louisiana';
wng_pageInfo.pageTitleTag='KPLC 7 News, Lake Charles, Louisiana';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffKPLC';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        /*Ad wnsz_1 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KPLC'},width:468,height:60,wncc:"News",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
/*Ad wnsz_41 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KPLC'},width:300,height:250,wncc:"News",parent:"WNAd43",type:"dom",realvu:"",sizes:[[300,250],[300,600]],application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_46 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_47 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KPLC'},width:300,height:250,wncc:"News",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_63 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["86"]={id:"86",wnsz:"86",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'inline',aff:'KPLC'},width:980,height:30,wncc:"News",parent:"WNAd86",type:"inline",realvu:"",sizes:[[728,90],[980,30],[970,250]],application:"banner"};
</script>
<script type="text/javascript" src="http://kplc.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2017-05-26%2014%3A11%3A03_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/KPLC.config.js?ver=Container-E.98_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=Container-E.98_7.3.9.93"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link href='http://fonts.googleapis.com/css?family=Open+Sans:400italic,400,700|Open+Sans+Condensed:700,300' rel='stylesheet' type='text/css'><script src="http://ftpcontent.worldnow.com/wncustom/custom/raycom/2015/custom-master.js"></script><script src="http://ftpcontent.worldnow.com/wncustom/custom/kplc/2015/custom.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/wncustom/custom/raycom/2015/custom-master.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/wncustom/custom/kplc/2015/custom.css" /></script><script src="http://ftpcontent4.worldnow.com/raycom/secondaryNav/2015/secnav-kplc.js"></script><script type="text/javascript" src="http://ftpcontent4.worldnow.com/raycom/custom/2015/raycom_custom_global.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent4.worldnow.com/raycom/custom/2015/raycom_custom_global.css" /><script type="text/javascript" src="http://ftpcontent4.worldnow.com/kplc/custom/2015/kplc-custom.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent4.worldnow.com/kplc/custom/2015/kplc-custom.css" /><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--></head><body id="WNAffKPLC" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KHQCXL" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-KHQCXL');</script><!--End Google Tag Manager--><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-142' ,"dma":'175' ,"group":'Raycom'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><h1>Mold discovered in Sulphur's Central Fire Station - KPLC 7 News, Lake Charles, Louisiana</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/search"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google_logo.png' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://kplc.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://kplc.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu66" class="wnMainMenu"><div class="wnHorizontal"><div class="wnDynamic"><div class="wnMenuTypeText"><ul class="wnLevel1" id="submenu66"><li class="wnFirstNode" id="menu66_1-C4382"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/">HOME</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu66_1-C4382"><li class="wnFirstNode" id="menu66_1_1-S35534484"><span><a href="/story/35534484/lincoln-county-shooting-leaves-8-dead-including-sheriffs-deputy">Lincoln County shooting leaves 8 dead, including sheriff's deputy</a></span></li><li class="" id="menu66_1_2-C216258"><span><a href="/category/216258/preference-center">Mobile Alerts</a></span></li><li class="" id="menu66_1_3-L716711"><span><a href="http://www.kplctv.com/category/5847/kplc-links">KPLC TV Links</a></span></li><li class="" id="menu66_1_4-C292737"><span><a href="/category/292737/kplc-gas-price-tracker">KPLC Gas Price Tracker</a></span></li><li class="" id="menu66_1_5-C5875"><span><a href="/category/5875/7stormteam-hurricane-center">Hurricane Center</a></span></li><li class="" id="menu66_1_6-C281274"><span><a href="/category/281274/right-this-minute-video-landing-page">Right This Minute Video Coverage</a></span></li><li class="" id="menu66_1_7-C162901"><span><a href="/category/162901/ap-news-center">U.S. &amp; World News</a></span></li></ul></li><li class="" id="menu66_2-C4384"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/4384/news">News</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu66_2-C4384"><li class="wnFirstNode" id="menu66_2_1-C15054"><span><a href="/pop_video_top">Top Video Clips</a></span></li><li class="" id="menu66_2_2-C318514"><span><a href="/category/318514/legal-corner">Legal Corner</a></span></li><li class="" id="menu66_2_3-C317810"><span><a href="/category/317810/does-it-work">Does It Work</a></span></li><li class="" id="menu66_2_4-C286397"><span><a href="/category/286397/i-wanna-know">I Wanna Know</a></span></li><li class="" id="menu66_2_5-C77699"><span><a href="/category/77699/consider-this-editorial-kplc">Consider This</a></span></li><li class="" id="menu66_2_6-C283330"><span><a href="/category/283330/the-new-family-tree">The New Family Tree</a></span></li><li class="" id="menu66_2_7-C19983"><span><a href="/category/19983/hometown-heroes">Hometown Heroes</a></span></li><li class="" id="menu66_2_8-C286390"><span><a href="/category/286390/7-on-your-side">7 On Your Side</a></span></li><li class="" id="menu66_2_9-C212690"><span><a href="/category/212690/more-slideshows">Slideshows</a></span></li><li class="" id="menu66_2_10-C317809"><span><a href="/category/317809/stretch-your-dollar">Stretch Your Dollar</a></span></li></ul></li><li class="" id="menu66_3-C4383"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather">WEATHER</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu66_3-C4383"><li class="wnFirstNode" id="menu66_3_1-C306585"><span><a href="/category/306585/7-day-forecast">7 Day Forecast</a></span></li><li class="" id="menu66_3_2-S31451306"><span><a href="/story/31451306/latest-river-stages-forecasts">Latest river stages, forecasts</a></span></li><li class="" id="menu66_3_3-C5875"><span><a href="/category/5875/7stormteam-hurricane-center">Hurricane Center</a></span></li><li class="" id="menu66_3_4-C284966"><span><a href="/category/284966/sky-cam-network">SkyCams</a></span></li><li class="" id="menu66_3_5-C313166"><span><a href="/category/313166/first-alert-allergen-index">First Alert Allergen Index</a></span></li><li class="" id="menu66_3_6-L762463"><span><a href="http://www.kplctv.com/category/310496/marine-forecast-and-tide-times">Marine Forecast and Tide Times</a></span></li><li class="" id="menu66_3_7-L719017"><span><a href="http://www.kplctv.com/category/62491/fishing-forecast">Fishing &amp; Hunting Forecast</a></span></li><li class="" id="menu66_3_8-L91497"><span><a href="javascript:OpenWin('http://www.weather.gov/lakecharles||height=,width=,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">National Weather Service</a></span></li><li class="" id="menu66_3_9-C200674"><span><a href="/category/200674/kplc-weather-active-daily">KPLC Personal Forecast</a></span></li><li class="" id="menu66_3_10-S12318621"><span><a href="/story/12318621/programming-your-midland-noaa-weather-radio">Programming a Midland Weather Radio</a></span></li><li class="" id="menu66_3_11-L633644"><span><a href="javascript:OpenWin('http://www.facebook.com/benterrykplc||height=700,width=600,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Ben's Facebook</a></span></li><li class="" id="menu66_3_12-L633649"><span><a href="javascript:OpenWin('http://www.facebook.com/wadehamptonkplc||height=700,width=600,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Wade's Facebook</a></span></li></ul></li><li class="" id="menu66_4-C4385"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/4385/sports">SPORTS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu66_4-C4385"><li class="wnFirstNode" id="menu66_4_1-C172802"><span><a href="/category/172802/touchdown-live">Touchdown Live</a></span></li><li class="" id="menu66_4_2-C245115"><span><a href="/category/245115/lsu">LSU</a></span></li><li class="" id="menu66_4_3-C248779"><span><a href="/category/248779/sec-originals">SEC Football</a></span></li><li class="" id="menu66_4_4-C245114"><span><a href="/category/245114/mcneese-state">McNeese State Sports</a></span></li><li class="" id="menu66_4_5-C245117"><span><a href="/category/245117/saints">Saints and NFL</a></span></li><li class="" id="menu66_4_6-C245118"><span><a href="/category/245118/high-school-sports">High School Sports</a></span></li><li class="" id="menu66_4_7-C245119"><span><a href="/category/245119/sports-person-of-the-week">Sports Person Of The Week</a></span></li><li class="" id="menu66_4_8-C261012"><span><a href="/category/261012/outdoors">Outdoors</a></span></li></ul></li><li class="" id="menu66_5-C284966"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/284966/sky-cam-network">SkyCams</a></span></span></span></span></li><li class="" id="menu66_6-C5841"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/5841/health-family">HEALTH</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu66_6-C5841"><li class="wnFirstNode" id="menu66_6_1-L705939"><span><a href="http://www.kplctv.com/category/5841/health-family">Health and Family</a></span></li><li class="" id="menu66_6_2-C283330"><span><a href="/category/283330/the-new-family-tree">The New Family Tree</a></span></li><li class="" id="menu66_6_3-L527002"><span><a href="http://www.kplctv.com/category/227058/focus-on-health">Focus on Health</a></span></li><li class="" id="menu66_6_4-C72891"><span><a href="/category/72891/health-source-online">Health Source Online</a></span></li></ul></li><li class="" id="menu66_7-L426414"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/link/426414/program-listings">Program Guide</a></span></span></span></span></li><li class="" id="menu66_8-C5844"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/5844/community">Community</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu66_8-C5844"><li class="wnFirstNode" id="menu66_8_1-L735666"><span><a href="https://swlaconnected.com">SWLA Connected</a></span></li><li class="" id="menu66_8_2-C175244"><span><a href="/category/175244/coupon-bug">Coupon Bug</a></span></li><li class="" id="menu66_8_3-C95979"><span><a href="/category/95979/traffic-watch">Traffic Watch</a></span></li><li class="" id="menu66_8_4-C6679"><span><a href="/category/6679/kplc-recipes">KPLC Kitchen</a></span></li></ul></li><li class="" id="menu66_9-C69123"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/69123/kplc-contest-page">Contests</a></span></span></span></span></li><li class="" id="menu66_10-C5845"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/5845/about-us">About Us</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu66_10-C5845"><li class="wnFirstNode" id="menu66_10_1-S138117"><span><a href="/story/138117/contact-us">Contact KPLC</a></span></li><li class="" id="menu66_10_2-S16635466"><span><a href="/story/16635466/copies-of-news-stories">Request a copy of a news story</a></span></li><li class="" id="menu66_10_6-S138040"><span><a href="/story/138040/advertising-on-kplc-and-kplctvcom">Advertising on KPLC and kplctv.com</a></span></li><li class="" id="menu66_10_3-L691885"><span><a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&amp;searchKeyword=&amp;searchLocation=-12802-Lake+Charles&amp;searchCategory=">Jobs at KPLC</a></span></li><li class="" id="menu66_10_4-S25277271"><span><a href="/story/25277271/kplc-internships">KPLC Internships</a></span></li><li class="" id="menu66_10_7-L179379"><span><a href="javascript:OpenWin('http://www.raycommedia.com||height=,width=,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Raycom Media</a></span></li><li class="" id="menu66_10_5-C184304"><span><a href="/category/184304/kplc-production-profile">KPLC Production Profile</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu66"></div></div></div></div><div id="spacermenu66" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu66', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : false, level1ArrowPadding : '15', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNAd86" class="wnad wnad86">
<script>wnad_86.load();</script></div>
<!--END wnAdSize-->
<div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div></div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Mold discovered in Sulphur's Central Fire Station</h3>
<time datetime="2017-02-25T04:18:36Z" class="publisheddate wn-time gmt dst-switch">2017-02-25T04:18:36Z</time><time datetime="2017-02-25T04:40:41Z" class="updateddate wn-time gmt dst-switch">2017-02-25T04:40:41Z</time><style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div id="WNStoryByline" class="bylines wn-row"><div class="byline wn-row"><span class="author">By Maranda Whittington, Reporter</span><div class="simple"><span class="bio item"><a target="_blank" title="" href="http://www.kplctv.com/story/32250302/maranda-whittington">Bio</a></span><span class="email item"><a target="_self" title="" href="mailto:mwhittington@kplctv.com?body=http://www.kplctv.com/story/34602501/mold-discovered-in-sulphurs-central-fire-station">Email</a></span></div><div class="wn-anchor"><a href="#" class="connect">Connect</a><div class="connect off"><div class="bio item"><a target="_blank" title="" href="http://www.kplctv.com/story/32250302/maranda-whittington">Biography</a></div><div class="email item"><a target="_self" title="" href="mailto:mwhittington@kplctv.com?body=http://www.kplctv.com/story/34602501/mold-discovered-in-sulphurs-central-fire-station">mwhittington@kplctv.com</a></div><div class="facebook item"><div class="fb-follow" data-colorscheme="light" data-layout="button" data-show-faces="false" data-href="https://www.facebook.com/MarandaWhittingtonKPLC"></div></div><div class="twitter item"><a class="twitter-follow-button" data-show-count="false" data-lang="en" data-show-screen-name="false" href="https://twitter.com/MarandaKPLC">Follow @MarandaKPLC</a></div></div></div></div></div><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div></div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnRight" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://kplc.images.worldnow.com/images/13218555_G.jpg" alt="(Source: Maranda Whittington/KPLC)" title="(Source: Maranda Whittington/KPLC)" border="0" width="180">
<span>(Source: Maranda Whittington/KPLC)</span></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated right"><span id="WNStoryDateline">SULPHUR, LA (KPLC) -
            </span><p>Taxpayers in Sulphur may soon be reaching into their pockets to either repair or replace one of their local fire stations - all because of mold.&nbsp;</p><p>&ldquo;I can confirm there is some mold in there,&rdquo; said Mayor Chris Duncan.&nbsp;</p><p>The &ldquo;there&rdquo; is&nbsp;the Sulphur Central Fire Department. Officials discovered the mold in the building earlier this month.</p><p>&ldquo;We had some moisture running down the walls inside and apparently, it could have been a leak over a long time,&rdquo; said Duncan.&nbsp;</p><p>The Sulphur City Council held a special meeting and it declared the mold a public emergency - closing parts of the station - and moved the firefighters to a temporary trailer out front.</p><p>&nbsp;Mayor Duncan says that so far at least $7,000&nbsp;has been spent on testing not only the fire station, but also the city&rsquo;s fire fighters and with all that money being spent is there a chance for a new fire station?</p><p>&ldquo;There always is that possible chance of it, where if it&rsquo;s going to cost up to three-quarters of the cost, or even a half of the cost, to do the repairs on this. Is it better to build a new building and have a state of the art building here for the future?&quot; said Duncan. &quot;That&rsquo;s something we are evaluating right now.&rdquo;</p><p>Duncan said if the station has to permanently shut down the city recently received a $1.3 billion&nbsp;bond that could pay for a new one.</p><p>&ldquo;We think we can actually do that with this money if need be to use it here but we just have to confirm it with our bond attorney and the bond commission to make sure we&rsquo;re safe and protected,&rdquo; he said.&nbsp;</p><p>As for the health of the firefighters.&nbsp;</p><p>&ldquo;There&rsquo;s a lot of rumors going around on the streets in regards to their health and everything, and all I can tell you is we&rsquo;ve given the option to take some preliminary evaluations on it,&quot; said Duncan.&nbsp;</p><p>&nbsp;He assured the public that they are safe and the station can still perform their duties. &nbsp;</p><p>&ldquo;Our citizens are protected; the fire station here is open; it's available and as a matter of fact. they are rolling from here,&rdquo; said Duncan.</p><p>Another inspection is in the process to discover what kind of mold is in the building. Duncan said they will find out the results in a few weeks.&nbsp;</p><p><em>Copyright 2017&nbsp;</em><a href="http://www.kplctv.com/"><em>KPLC</em></a><em>. All rights reserved.</em></p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 8-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Headline Box - Col 4 (78)--><div class="wnBlock displaySize displaySizeId78 headlineBox" id="DisplaySizeId78"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">More Local News</span><span class="text abridgedHeadline">News</span><a class="wnContent more enabled" href="/category/4384/news"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem advertisement">
</li><li class="wnItem feature Weather story priority-1 odd displaySizeId-7 odd-7"><meta content="Weather"><meta content="2017-05-29 07:40:39"><h4 class="wnContent sectionTitle"><span class="text">FIRST ALERT FORECAST: A wet week ahead for SW Louisiana</span></h4><h4 class="wnContent headline"><a href="/story/35537376/first-alert-forecast-a-wet-week-ahead-for-sw-louisiana"><span class="text">FIRST ALERT FORECAST: A wet week ahead for SW Louisiana</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35537376/first-alert-forecast-a-wet-week-ahead-for-sw-louisiana"><span class="text">FIRST ALERT FORECAST: A wet week ahead for SW Louisiana</span></a></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Monday, May 29 2017 3:40 AM EDT</span><span class="wnContent timestamp gmttime">2017-05-29 07:40:39 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35537376/first-alert-forecast-a-wet-week-ahead-for-sw-louisiana"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/14002834_G.png" title="Rainfall totals through Sunday" alt="Rainfall totals through Sunday"></a><span class="caption left width90"><span class="text">Rainfall totals through Sunday</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35537376/first-alert-forecast-a-wet-week-ahead-for-sw-louisiana"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/14002834_G.png"></a></div><div class="wnContent summary abridged"><span class="text">Overall confidence on exact timing with regards to the highest rain chances this week is low since our storms will be directly associated to the development and placement of a series of larger scale thunderstorm complexes developing in other parts of the region that will send rain cooled outflow boundaries our direction, triggering additional showers and thunderstorms closer to home.  In layman&rsquo;s terms, our storms on Sunday resulted from outflow boundaries from thunderstorms tha...</span><a class="more" href="/story/35537376/first-alert-forecast-a-wet-week-ahead-for-sw-louisiana"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Overall confidence on exact timing with regards to the highest rain chances this week is low since our storms will be directly associated to the development and placement of a series of larger scale thunderstorm complexes developing in other parts of the region that will send rain cooled outflow boundaries our direction, triggering additional showers and thunderstorms closer to home.  In layman&rsquo;s terms, our storms on Sunday resulted from outflow boundaries from thunderstorms tha...</span><a class="more" href="/story/35537376/first-alert-forecast-a-wet-week-ahead-for-sw-louisiana"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-2 even displaySizeId-7 even-7"><meta content="News"><meta content="2017-05-28 22:11:27"><h4 class="wnContent headline"><a href="/story/35536235/a-modern-day-sandlot-comes-to-lake-charles"><span class="text">A modern-day 'Sandlot' comes to Lake Charles</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35536235/a-modern-day-sandlot-comes-to-lake-charles"><span class="text">A modern-day 'Sandlot' comes to Lake Charles</span></a></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, May 28 2017 7:54 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-28 23:54:49 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35536235/a-modern-day-sandlot-comes-to-lake-charles"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/14000877_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35536235/a-modern-day-sandlot-comes-to-lake-charles"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/14000877_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>A group of boys are taking&nbsp;their love for baseball off the field and into the backyard. And no, this isn't a&nbsp;scene out of the 1993 classic&nbsp;&quot;The Sandlot.&quot; It&rsquo;s happening right here in Lake Charles.</p><p>At the David household, there's something special going on in the backyard.</p><p>&ldquo;One day in the backyard we came out here and decided to start playing around,&rdquo; said Dylan David, who started&nbsp;a Wiffle ball league with his friends.</p></span><a class="more" href="/story/35536235/a-modern-day-sandlot-comes-to-lake-charles"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A group of boys are taking&nbsp;their love for baseball off the field and into the backyard. And no, this isn't a&nbsp;scene out of the 1993 classic&nbsp;&quot;The Sandlot.&quot; It&rsquo;s happening right here in Lake Charles.</p><p>At the David household, there's something special going on in the backyard.</p><p>&ldquo;One day in the backyard we came out here and decided to start playing around,&rdquo; said Dylan David, who started&nbsp;a Wiffle ball league with his friends.</p></span><a class="more" href="/story/35536235/a-modern-day-sandlot-comes-to-lake-charles"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-3 odd displaySizeId-7 odd-7"><meta content="News"><meta content="2017-05-28 16:47:35"><h4 class="wnContent headline"><a href="/story/35535205/bolton-ford-holds-3rd-annual-give-a-wish-car-show-benefit"><span class="text">Bolton Ford holds 3rd annual Give A Wish benefit</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35535205/bolton-ford-holds-3rd-annual-give-a-wish-car-show-benefit"><span class="text">Bolton Ford holds 3rd annual Give A Wish benefit</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, May 28 2017 1:14 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-28 17:14:57 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35535205/bolton-ford-holds-3rd-annual-give-a-wish-car-show-benefit"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/14000061_G.jpg" title="(Source: KPLC)" alt="(Source: KPLC)"></a><span class="caption left width90"><span class="text">(Source: KPLC)</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35535205/bolton-ford-holds-3rd-annual-give-a-wish-car-show-benefit"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/14000061_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Bolton Ford held its third annual car and truck show benefiting the Give A Wish foundation&nbsp;on Saturday. Give A Wish announced they would be sending Kenzie Noelle Johnson to Disney World. They also gave Johnson her own set of wheels: a fun-size pink Ford Mustang. Paula Livingston, the director of Give A Wish, said it takes thousands of dollars for the organization to make dreams a reality.</p></span><a class="more" href="/story/35535205/bolton-ford-holds-3rd-annual-give-a-wish-car-show-benefit"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Bolton Ford held its third annual car and truck show benefiting the Give A Wish foundation&nbsp;on Saturday. Give A Wish announced they would be sending Kenzie Noelle Johnson to Disney World. They also gave Johnson her own set of wheels: a fun-size pink Ford Mustang. Paula Livingston, the director of Give A Wish, said it takes thousands of dollars for the organization to make dreams a reality.</p></span><a class="more" href="/story/35535205/bolton-ford-holds-3rd-annual-give-a-wish-car-show-benefit"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-4 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-05-27 23:30:42"><h4 class="wnContent headline"><a href="/story/35533377/sales-tax-break-on-hurricane-items-this-weekend"><span class="text">Sales tax break on hurricane items this weekend</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35533377/sales-tax-break-on-hurricane-items-this-weekend"><span class="text">Sales tax break on hurricane items this weekend</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, May 28 2017 9:49 AM EDT</span><span class="wnContent timestamp gmttime">2017-05-28 13:49:07 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35533377/sales-tax-break-on-hurricane-items-this-weekend"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/13997883_G.jpg" title="(Source: Maranda Whittington/KPLC)" alt="(Source: Maranda Whittington/KPLC)"></a><span class="caption left width90"><span class="text">(Source: Maranda Whittington/KPLC)</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35533377/sales-tax-break-on-hurricane-items-this-weekend"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/13997883_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Flashlights, tarps, fuel cans, and lanterns. These are just some of the many items Carolyn Trahan sells at Trahan Hardware. With hurricane season approaching, Trahan and her employees like Jeremy Jolviette are usually selling these types of items right before a hurricane.&nbsp;&quot;Everyone is trying to get prepared for it,&quot; said Jolviette.&nbsp;The Louisiana Department of Revenue has declared this weekend a hurricane preparedness sales tax holiday.&nbsp;All hurrica...</p></span><a class="more" href="/story/35533377/sales-tax-break-on-hurricane-items-this-weekend"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Flashlights, tarps, fuel cans, and lanterns. These are just some of the many items Carolyn Trahan sells at Trahan Hardware. With hurricane season approaching, Trahan and her employees like Jeremy Jolviette are usually selling these types of items right before a hurricane.&nbsp;&quot;Everyone is trying to get prepared for it,&quot; said Jolviette.&nbsp;The Louisiana Department of Revenue has declared this weekend a hurricane preparedness sales tax holiday.&nbsp;All hurrica...</p></span><a class="more" href="/story/35533377/sales-tax-break-on-hurricane-items-this-weekend"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-5 odd displaySizeId-7 odd-7 collapsed last"><meta content="News"><meta content="2017-05-27 03:24:08"><h4 class="wnContent headline"><a href="/story/35530422/50-years-later-lake-charles-opens-its-time-capsule"><span class="text">Lake Charles opens time capsule buried 50 years ago</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Saturday, May 27 2017 3:16 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-27 19:16:59 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35530422/50-years-later-lake-charles-opens-its-time-capsule"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/13994885_G.jpg" title="(Source: Maranda Whittington/KPLC)" alt="(Source: Maranda Whittington/KPLC)"></a><span class="caption left width90"><span class="text">(Source: Maranda Whittington/KPLC)</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35530422/50-years-later-lake-charles-opens-its-time-capsule"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/13994885_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>On Friday Mayor Randy Roach helped pull out history - 50 years worth, to be exact.</p><p>In 1967 a time capsule was buried in front of historic Lake Charles City Hall, and many had different ideas of what could be buried inside.&nbsp;</p></span><a class="more" href="/story/35530422/50-years-later-lake-charles-opens-its-time-capsule"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>On Friday Mayor Randy Roach helped pull out history - 50 years worth, to be exact.</p><p>In 1967 a time capsule was buried in front of historic Lake Charles City Hall, and many had different ideas of what could be buried inside.&nbsp;</p></span><a class="more" href="/story/35530422/50-years-later-lake-charles-opens-its-time-capsule"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId78');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Headline Box - Col 4 (78)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text abridgedHeadline">Stay In Touch</span><a class="wnContent more enabled" href="/category/113275/stay-in-touch"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature News category priority-1 odd displaySizeId-1 odd-1"><meta content="News"><meta content=""><h4 class="wnContent headline"><a href="/category/113279/sign-up-for-kplc-e-news"><span class="text">Sign Up for KPLC E-News</span></a></h4><h4 class="wnContent headline abridged"><a href="/category/113279/sign-up-for-kplc-e-news"><span class="text">Sign Up for KPLC E-News</span></a></h4><div class="wnContent summaryImage left width90"><a href="/category/113279/sign-up-for-kplc-e-news"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/113279_CS.jpg"></a></div><div class="wnContent summaryImage abridged left width50"><a href="/category/113279/sign-up-for-kplc-e-news"><img border="0" width="50" data-path="http://kplc.images.worldnow.com/images/113279_CA.jpg"></a></div><div class="wnContent summary"><span class="text">Get the latest news updates sent right to your computer or mobile device.</span><a class="more" href="/category/113279/sign-up-for-kplc-e-news"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature  link priority-2 even displaySizeId-1 even-1 last"><meta content=""><meta content=""><h4 class="wnContent headline"><a href="http://www.kplctv.com/link/495446/download-our-new-app"><span class="text">Download the new KPLC app!</span></a></h4><h4 class="wnContent headline abridged"><a href="http://www.kplctv.com/link/495446/download-our-new-app"><span class="text">Download the new KPLC app!</span></a></h4><div class="wnContent summaryImage left width90"><a href="http://www.kplctv.com/link/495446/download-our-new-app"><img border="0" width="90" data-path="http://kplc.images.worldnow.com/images/183268_LS.gif"></a></div><div class="wnContent summary abridged"><span class="text">Local News, Weather, Traffic, Sports, Stocks, Movies on your Cell Phone</span><a class="more" href="http://www.kplctv.com/link/495446/download-our-new-app"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Get local news, weather, sports, and video on your mobile device.</span><a class="more" href="http://www.kplctv.com/link/495446/download-our-new-app"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://kplc.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText"><div id="CDEV-footer">
	<div class="top"> 
		<div class="search-box">
			<div class="wnSearchBox" id="WNSearchBox-bottom"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><span>Can't Find Something? </span><input type="text" class="wnQueryText" name="qu" size="20" value="" placeholder="Search For It Here"><input type="submit" class="wnSubmit" value="Search"></form></div>			
		</div>
		<div class="station-info">
			<div class="logo"><img src="http://ftpcontent.worldnow.com/wncustom/custom/kplc/2015/images/kplc-footer-logo.png" width="103" height="98" border="0" /></div>
			<div class="contact">
				<div>320 Division Street<br>Lake Charles, LA 70601/70602</div>
				<div>(337) 439-9071</div>
			</div>
			<div class="fcc">
				<div><a href="https://publicfiles.fcc.gov/tv-profile/kplc">FCC Public File</a></div>
				<a href="mailto:publicfile@kplctv.com">publicfile@kplctv.com</a>
				<div>(337) 439-9071 ext. 507</div>
				<a href="/story/9753976/kplc-public-eeo-report">EEO Report</a>
				<a href="/story/12173010/how-to-file-a-closed-captioning-complaint">Closed Captioning</a>
			</div>			
		</div>
	</div>
	<div class="footer-main-nav"> 
		<ul class="link-group">
			<!--<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>-->
		</ul>
	</div>	
	<div class="news-link"> 
		<ul class="link-group">
			<li><a href="http://www.ktre.com/category/241993/texas-news-now">Texas News Now</a></li>
		</ul>
	</div>	
	<div class="bottom">
		<div class="copyrightText">
			<a id="wnLogo" href="http://www.worldnow.com"><img src="http://ftpcontent.worldnow.com/wncorp/logos/worldnow_white.png" id="wn"></a>
        	<div class="text">
				All content &copy; Copyright 2000 - 2017 Raycom Media. All Rights Reserved. For more information on this site, please read our <a href="/story/8774923/privacy-policy">Privacy Policy</a>, and <a href="/story/8775106/terms-of-service">Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.
        	</div>
        	<div class="clear"></div>       
		</div>	
	</div>
</div></div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script src="http://ftpcontent4.worldnow.com/raycom/js/global-footer.js"></script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>