<!DOCTYPE html> <html lang="en-US"><head> <script>var pb_global={pageName:"article-template",pageId:"rUmune2BwXje1r",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"kplc"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "kplc/web/news/national",
    "authors": [
                  
                ],
    "canonicalUrl": "/2018/08/30/man-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog/",
    "contentId": "MMALD66DA5C7TLKARYDC6NEW4I",
    "contentName": "Man who hired dog sitter finds two shirtless men, lube, neglected dog",
    "contentOwner": "digital-content-center",
    "contentTags":  [
                  
                    {
                      "text": "national",
                      "description": "national",
                      "slug": "national"
                    },
                  
                    {
                      "text": "pet care",
                      "description": "pet care",
                      "slug": "pet-care"
                    },
                  
                ],
    "contentType": "story",
    "datePublished": "2018-08-30T11:13:42.876Z",
    "description": "The woman agreed to watch a man's dog. However, when the owner returned to his house, he walked into a hair-raising situation.",
    "hasVideo": "true",
    "metaDescription": "The woman agreed to watch a man's dog. However, when the owner returned to his house, he walked into a hair-raising situation.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                          {
                            "name": "National",
                            "_id": "/news/national",
                            "path": "/news/national",
                          }
                        ,
    "publishedDay": "30",
    "publishedMonth": "08",
    "publishedYear": "2018",
    "stationName": "kplc",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]
  
</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="k2k00ABXD6ssT0aA9jSLcfEt6XTbAVdVQupaocyxkH8"/> <title>Man who hired dog sitter finds two shirtless men, lube, neglected dog</title> <meta name="keywords" content="sex, lube, Wag, dog sitting"> <meta name="news_keywords" content="sex, lube, Wag, dog sitting"/> <meta name="date" content="2018-08-30T11:13:44.236Z"/> <meta itemprop="description" name="description" content="The woman agreed to watch a man's dog. However, when the owner returned to his house, he walked into a hair-raising situation."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="/2018/08/30/man-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog/"> <meta name="twitter:title" content="Man who hired dog sitter finds two shirtless men, lube, neglected dog"/> <meta name="twitter:image" content="http://www.kplctv.com/resizer/ia9CapZXAGc1UI4FiZz6OkX1_5Q=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UY5UZCO7WVEPLELJX4IP4ICVL4.JPG"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="The woman agreed to watch a man's dog. However, when the owner returned to his house, he walked into a hair-raising situation."/> <meta name="twitter:site" content="@KPLC7News"/> <meta name="twitter:creator" content="@KPLC7News"> <meta property="og:url" content="/2018/08/30/man-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog/"/> <meta property="og:title" content="Man who hired dog sitter finds two shirtless men, lube, neglected dog"/> <meta itemprop="image" property="og:image" content="http://www.kplctv.com/resizer/ia9CapZXAGc1UI4FiZz6OkX1_5Q=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UY5UZCO7WVEPLELJX4IP4ICVL4.JPG"/> <meta property="og:description" content="The woman agreed to watch a man's dog. However, when the owner returned to his house, he walked into a hair-raising situation."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="http://www.kplctv.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="354227664672005"/> <meta property="fb:pages" content="99603912791"/> <meta property="fb:admins" content="644426401"/> <meta property="article:publisher" content="https://www.facebook.com/kplc7news"> <meta property="article:tag" content="national, pet care"> <meta name="author" content=""> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Man who hired dog sitter finds two shirtless men, lube, neglected dog",
        
        "image": {
          "@type": "ImageObject",
          "url": "http://www.kplctv.com/resizer/ia9CapZXAGc1UI4FiZz6OkX1_5Q=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UY5UZCO7WVEPLELJX4IP4ICVL4.JPG",
          "height": 400.0,
          "width": 1200
        },
        
        "datePublished": "2018-08-30T11:14:26.212Z",
        "dateModified": "2018-08-30T11:13:44.236Z",
        "articleBody": "The woman agreed to watch a man&#039;s dog. However, when the owner returned to his house, he walked into a hair-raising situation.COLORADO CITY, CO (KXRM/CNN) - It appears obedience school may be in order for one dog sitter.The woman agreed to watch a man&#039;s dog. However, when the owner returned to his house, he walked into a hair-raising situation.“The general smell in the house was just disgusting, I’ve had all the windows and doors open,” Klete Keller said.He came home around 1 a.m. and noticed two men without their shirts on sitting on the couch.&#034;There was an open bottle of personal lubricant and a camcorder on the end table, so it’s pretty self explanatory what was going on.&#034; Keller said.The dog sitter was nowhere to be seen. It turns out she was in the bathroom, showering.“But to be completely honest, I didn’t have WD-40 and my keys were stuck in my car so I ended up grabbing what I had in my car, for things, that you know, I do on my personal time and I didn’t think to put it back in my car,” said the dog sitter, who wanted to remain anonymous.Jimbo was locked in a bedroom, sitting in his own urine, acting terrified, his owner said.Keller said that wasn’t it, though. His sheets were also dirty, and as he looked closer, “there is also, what I can only assume, are bodily fluids on the couch.”&#034;I wouldn&#039;t know anything about that, because I know that I took a shower at his house and I sat on the couch in a towel and that was before my friends got there,&#034; she said.Keller said his dog Jimbo was also locked in a bedroom, sitting in his own urine, acting terrified.“It was just, just a total mess and I can only imagine what poor Jimbo saw in there,” Keller said.According to Wag, the platform Keller used to hire the sitter, the dog sitter had a rating of 4.96 out of 5 and had completed a combination of 305 walks and dog sittings.Wag also issued a statement regarding this matter which reads in part, &#034;We have launched an investigation into this incident and have suspended the sitter from our platform. … The circumstances around this incident are unacceptable and we expect everyone on our platform to conduct themselves in a professional manner.As far as her experience with Keller, though, the sitter apologized: “I’d like to apologize to him for making him feel like I violated his house because that wasn’t my intention, I misinterpreted information and I had guests over when I shouldn’t have.”Copyright 2018 KXRM via CNN. All rights reserved.",
        "author": [
          
            
            
              {
        "@type": "Organization",
        "name": "",
        "logo": {
          "@type": "ImageObject",
          "url": "http://www./pb/resources/images//logo_meta.png?token=123",
          "width": 467,
          "height": 60
        }
      }
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "",
        "logo": {
          "@type": "ImageObject",
          "url": "http://www./pb/resources/images//logo_meta.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "The woman agreed to watch a man's dog. However, when the owner returned to his house, he walked into a hair-raising situation."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "",
        "url": "http://",
        "logo": "http:////pb/resources/images/rm_icons/logo_meta.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/kplc7news" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/c80166d3efaf62924e37/rm/rm-frameworkc80166d3efaf62924e37.css?v=11" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/kplc-logo.svg?t=c80166d3efaf62924e37)}</style><link href="/pb/resources/dist/c80166d3efaf62924e37/rm/rm-frameworkc80166d3efaf62924e37.css?v=11" rel="stylesheet"/> <link href="/pb/resources/dist/c80166d3efaf62924e37/rm/rm-featuresc80166d3efaf62924e37.css?v=11" rel="stylesheet"/> <link href="/pb/resources/dist/c80166d3efaf62924e37/rm/rm-servicesc80166d3efaf62924e37.css?v=11" rel="stylesheet"/> <script async src="/pb/resources/dist/c80166d3efaf62924e37/rm/rm-indexc80166d3efaf62924e37.js?v=11"></script> <script src="/pb/gr/c/default/rUmune2BwXje1r/arcAdsJS/84612eb819.js?v=11"></script><script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative high-z-index col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="fLVp591BwXje1r"> <div id="sales-nav" class="background-grey-minimal hidden visible-desktop"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="https://kplc.incentrev.com/category/local" class="color-grey-dark">50/50 Thursdays</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="/community/restaurant-guide/" class="color-grey-dark">Coca Cola Restaurant Guide</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://kplcconnections.revrocket.us/" class="color-grey-dark">Connections</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="/community/the-pledge-of-allegiance/" class="color-grey-dark">The Pledge</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="/business/legal/legal-brief/" class="color-grey-dark">Legal Brief</a></li> </ul> </div> </div> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky z-index-nav-only col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0Vpt6wBwXje1r"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.kplctv.com"> <div class="logo logo-slim"></div> </a> </div> <div class="flex-3 flex-container-row spaced spaced-sm spaced-left spaced-right hidden-on-mobile"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/traffic" class="">Traffic</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news/crime" class="">Crime</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/health" class="">Health</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/contests" class="">Contests</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/programming/schedule" class="">TV</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About Us</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.cwtv.com/" class="">CW</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full high-z-index tray-open visible' : 'tray left-0 hidden width-full high-z-index hidden'" class="tray left-0 hidden width-full high-z-index"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/homepage" class="color-white">Home</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/live" class="color-white">Watch Live</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/apps/" class="color-white">Download Apps</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/pets/puppy-cam" class="color-white">Puppy Cam</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news" class="color-white">News</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/news/national" class="color-white">National</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/news/crime" class="color-white">Crime</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/editorial" class="color-white">Consider This</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/news/hometown-heroes" class="color-white">Hometown Heroes</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/business/legal" class="color-white">Legal Corner</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/weather" class="color-white">Weather</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/weather/cams" class="color-white">Cams</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/weather/hurricane" class="color-white">Hurricane Center</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/weather/weather-with-ben" class="color-white">Weather with Ben</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/weather/marine-forecast/" class="color-white">Marine Forecast</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/weather/fishing-forecast" class="color-white">Fishing & Hunting Forecast</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/sports" class="color-white">Sports</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/sports/athlete" class="color-white">Sports Person of the Week</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/sports/high-school" class="color-white">High School</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/sports/high-school/football" class="color-white">Football</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/sports/ncaa/lsu" class="color-white">LSU</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/sports/ncaa/mcneese-state" class="color-white">McNeese State</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/traffic" class="color-white">Traffic</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/traffic/gas-prices/" class="color-white">KPLC Gas Price Tracker</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/health" class="color-white">Health</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/health/pediatric-checklist/" class="color-white">Pediatric Checklist</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/community" class="color-white">Community</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/community/restaurant-guide/" class="color-white">CocaCola Restaurant Guide</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/community/calendar" class="color-white">Community Calendar</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/contests" class="color-white">Contests</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/cruisin-the-coast-contest/" class="color-white">Cruisin' The Coast Contest</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/contests/diamond-durrells-diamond-team-giveaway/" class="color-white">Diamond Durrell's Diamond Team Giveaway</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/contests/lake-area-marine-trophy-link/" class="color-white">Lake Area Marine Trophy Link Contest</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/contests/facebook-giveaway/" class="color-white">Facebook Giveaway</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/programming" class="color-white">TV</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/programming/schedule/" class="color-white">TV Listings</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/about-us" class="color-white">About Us</a> </h3> </li> </ul> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0h1SyJBwXje1r"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-kplc-breaking/" data-url="/pb/api/v2/render/feature" data-website="kplc" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fgizRU1CwXje1r"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/kplc-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="kplc"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="frzXM21CwXje1r"> <div id="ad1824-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1824" class="arcad ad-728x90"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1824",slotName:"kplc/web/news/national",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MMALD66DA5C7TLKARYDC6NEW4I"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="fvrrkW1CwXje1r"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Man who hired dog sitter finds two shirtless men, lube, neglected dog</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="cy7EMH1CwXje1r"> <section id="article-sharebar" class="col col-no-gutter desktop-1 hidden visible-desktop spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share flex-container-column text-align-right"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Man+who+hired+dog+sitter+finds+two+shirtless+men%2C+lube%2C+neglected+dog&amp;url=http%3A%2F%2Fwww.kplctv.com%2F2018%2F08%2F30%2Fman-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fa fa-twitter icon-light"></i> </button> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.kplctv.com%2F2018%2F08%2F30%2Fman-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog%2F&amp;title=Man+who+hired+dog+sitter+finds+two+shirtless+men%2C+lube%2C+neglected+dog', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fa fa-facebook-square icon-light"></i> </button> <a href="mailto:?subject=Man%20who%20hired%20dog%20sitter%20finds%20two%20shirtless%20men%2C%20lube%2C%20neglected%20dog&amp;body=Read%20more%20on%20Man%20who%20hired%20dog%20sitter%20finds%20two%20shirtless%20men%2C%20lube%2C%20neglected%20dog%20at%20http%3A%2F%2Fwww.kplctv.com%2F2018%2F08%2F30%2Fman-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog%2F"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <i class="fa fa-envelope-o icon-light"></i> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0vRieOCwXje1r"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> <span class="timestamp"> August 30, 2018 at 6:13 AM CDT - Updated August 30 at 6:14 AM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0vhbxzCwXje1r"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>COLORADO CITY, CO (KXRM/CNN) - It appears obedience school may be in order for one dog sitter.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The woman agreed to watch a man's dog. However, when the owner returned to his house, he walked into a hair-raising situation.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“The general smell in the house was just disgusting, I’ve had all the windows and doors open,” Klete Keller said.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>He came home around 1 a.m. and noticed two men without their shirts on sitting on the couch.</p> <div class="flex-container-column align-items-center hidden-on-desktop spaced spaced-top spaced-sm"> <div id="ad1879-sticky" class="flex-container-column hidden-desktop hidden-tablet "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm"> <div id="ad1879" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1879",slotName:"kplc/web/news/national/MMALD66DA5C7TLKARYDC6NEW4I",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"There was an open bottle of personal lubricant and a camcorder on the end table, so it’s pretty self explanatory what was going on." Keller said.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The dog sitter was nowhere to be seen. It turns out she was in the bathroom, showering.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“But to be completely honest, I didn’t have WD-40 and my keys were stuck in my car so I ended up grabbing what I had in my car, for things, that you know, I do on my personal time and I didn’t think to put it back in my car,” said the dog sitter, who wanted to remain anonymous.</p> <div class="flex-container-column align-items-center hidden visible-desktop spaced spaced-top spaced-sm"> <div id="ad712-sticky" class="flex-container-column hidden-mobile"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm"> <div id="ad712" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad712",slotName:"kplc/web/news/national/MMALD66DA5C7TLKARYDC6NEW4I",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"desktop",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Jimbo was locked in a bedroom, sitting in his own urine, acting terrified, his owner said." data-src="http://www.kplctv.com/resizer/eUJb4Gv0LkwhS8_rU-LlaDvdKhw=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UY5UZCO7WVEPLELJX4IP4ICVL4.JPG" src="http://www.kplctv.com/resizer/dgOEWrVIxfDky_Hj7ictRy08lMQ=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UY5UZCO7WVEPLELJX4IP4ICVL4.JPG"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Jimbo was locked in a bedroom, sitting in his own urine, acting terrified, his owner said. (Source: KXRM/CNN) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Keller said that wasn’t it, though. His sheets were also dirty, and as he looked closer, “there is also, what I can only assume, are bodily fluids on the couch.”</p> <div class="flex-container-column align-items-center hidden-on-desktop spaced spaced-top spaced-sm"> <div id="ad1890-sticky" class="flex-container-column hidden-desktop hidden-tablet "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm"> <div id="ad1890" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1890",slotName:"kplc/web/news/national/MMALD66DA5C7TLKARYDC6NEW4I",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"I wouldn't know anything about that, because I know that I took a shower at his house and I sat on the couch in a towel and that was before my friends got there," she said.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Keller said his dog Jimbo was also locked in a bedroom, sitting in his own urine, acting terrified.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“It was just, just a total mess and I can only imagine what poor Jimbo saw in there,” Keller said.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>According to Wag, the platform Keller used to hire the sitter, the dog sitter had a rating of 4.96 out of 5 and had completed a combination of 305 walks and dog sittings.</p> <div class="flex-container-column align-items-center hidden-on-desktop spaced spaced-top spaced-sm"> <div id="ad276-sticky" class="flex-container-column hidden-desktop hidden-tablet "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm"> <div id="ad276" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad276",slotName:"kplc/web/news/national/MMALD66DA5C7TLKARYDC6NEW4I",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Wag also issued a statement regarding this matter which reads in part, "We have launched an investigation into this incident and have suspended the sitter from our platform. … The circumstances around this incident are unacceptable and we expect everyone on our platform to conduct themselves in a professional manner.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>As far as her experience with Keller, though, the sitter apologized: “I’d like to apologize to him for making him feel like I violated his house because that wasn’t my intention, I misinterpreted information and I had guests over when I shouldn’t have.”</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2018 KXRM via CNN. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f0UdjkkCwXje1r"> <div id="outbrain-article-ad" class=" "> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="http://www.kplctv.com/2018/08/30/man-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="http://www.kplctv.com/2018/08/30/man-who-hired-dog-sitter-finds-two-shirtless-men-lube-neglected-dog/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fyAqkl1CwXje1r"> <div id="ad686-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad686" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad686",slotName:"kplc/web/news/national",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MMALD66DA5C7TLKARYDC6NEW4I"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> <div class="pb-container"> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="fQY4Ro1CwXje1r"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-partly-cloudy" data-default-location-code="USLA0264" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="kplc" data-location-code="USLA0264" data-content-config-keys='Code' data-content-config-values='USLA0264'/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="http://www.kplctv.com/weather"> <img class="radar-image" src="http://webpubcontent.raycommedia.com/kplc/weather/ESP%20NEW_thumb.JPG" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="76" data-temp-c="24"> 76</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/66_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in <br/>Lake Charles, LA</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="http://www.kplctv.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast </button> </a> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0Kbix2CwXje1r"> <div id="ad464-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad464" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad464",slotName:"kplc/web/news/national",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MMALD66DA5C7TLKARYDC6NEW4I"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> <div class="pb-container"> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-homepage-story-feed" id="f0PZduFCwXje1r"> <div class="flex-feature height-full"> <h3 class="bold"><span class="rectangle"></span> LATEST NEWS</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-30147" data-content-service='content-feed'> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/house-system-elementary-school-promotes-good-behavior/"> <img class="width-full " alt="‘House system’ at elementary school promotes good behavior" src="http://www.kplctv.com/resizer/bpjKRz9JOEzlgemwOeqZwD92ekM=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/TOJPGKOOEJHDRFOYVB6WP4O6NQ.jpg"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/house-system-elementary-school-promotes-good-behavior/"><i class='far fa-play-circle' title='Has Video'></i>&nbsp; ‘House system’ at elementary school promotes good behavior</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Olivia Vidal</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/motorcycle-accident-la-prater-road-sulphur-avoid-area/"> <img class="width-full " alt="Motorcycle accident on LA 90 and Prater Road in Sulphur, avoid the area" src="http://www.kplctv.com/resizer/8-VGtXUJYKtq5PWibljLZsqXVfc=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/YX33RCV2URCF5KVDJPLADR7LJU.PNG"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/motorcycle-accident-la-prater-road-sulphur-avoid-area/"> Motorcycle accident on LA 90 and Prater Road in Sulphur, avoid the area</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Tresia Bowles</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/dequincy-native-donates-kidney-after-woman-she-hadnt-spoken-years-needs-transplant/"> <img class="width-full " alt="Dequincy native donates kidney after woman she hadn’t spoken to in 37 years needs transplant" src="http://www.kplctv.com/resizer/vu7Pwaax2-S-CA29vDCtx7KTYOc=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/HBDBW3UEOZHX7P2DGJTPPWWMAY.PNG"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/dequincy-native-donates-kidney-after-woman-she-hadnt-spoken-years-needs-transplant/"><i class='far fa-play-circle' title='Has Video'></i>&nbsp; Dequincy native donates kidney after woman she hadn’t spoken to in 37 years needs transplant</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Kayla Courvell</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/first-alert-forecast-rain-chances-increasing-this-weekend/"> <img class="width-full " alt="FIRST ALERT FORECAST: Rain chances increasing this weekend" src="http://www.kplctv.com/resizer/8FplzlUq4MvAFtXXr0cg5zpQ4ac=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/UTA3CPJ3FZBJ7FPAXJKMAAH5L4.JPG"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/first-alert-forecast-rain-chances-increasing-this-weekend/"> FIRST ALERT FORECAST: Rain chances increasing this weekend</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Gabrielle Espinosa</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/study-kayouche-coulee-underway-year-after-harvey/"> <img class="width-full " alt="Study of Kayouche Coulee underway a year after Harvey" src="http://www.kplctv.com/resizer/TW2GbwPS6Adm6mQa7yxwDS8o1K4=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/YKJMNARKU5AJNLLDZ2O5QRTRVE.bmp"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/study-kayouche-coulee-underway-year-after-harvey/"><i class='far fa-play-circle' title='Has Video'></i>&nbsp; Study of Kayouche Coulee underway a year after Harvey</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Jillian Corder</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/ts-cooley-elementary-magnet-school-becomes-nationally-certified/"> <img class="width-full " alt="T.S. Cooley Elementary Magnet School becomes nationally certified" src="http://www.kplctv.com/resizer/RPwYkAGFV8rfZ2nFVnzVhMJm1LA=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/FTAWNQQJ5NA3JOVTDUNAB7L5EE.jpg"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/ts-cooley-elementary-magnet-school-becomes-nationally-certified/"><i class='far fa-play-circle' title='Has Video'></i>&nbsp; T.S. Cooley Elementary Magnet School becomes nationally certified</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Drew Marine</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/residents-concerned-after-home-invasion/"> <img class="width-full " alt="Residents concerned after home invasion" src="http://www.kplctv.com/resizer/M5JACpQ6SHHhN7d6wt1IyfBXoFw=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/3CKS6CROSRE2TGY32NXTOSKLUE.PNG"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/residents-concerned-after-home-invasion/"><i class='far fa-play-circle' title='Has Video'></i>&nbsp; Residents concerned after home invasion</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Luke Burdsall</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-12 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/08/30/no-mcneese-preparing-open-season-northern-colorado/"> <img class="width-full " alt="No. 17 McNeese preparing to open the season at Northern Colorado" src="http://www.kplctv.com/resizer/12BwPaO26kKDg4ITTnRVyurHsRE=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/CBLQB35HIBEKPLHATWYHN7MYMI.JPG"/> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h5 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/08/30/no-mcneese-preparing-open-season-northern-colorado/"><i class='far fa-play-circle' title='Has Video'></i>&nbsp; No. 17 McNeese preparing to open the season at Northern Colorado</a></h5> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs height-full align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Brady Renard</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="frtAYb1CwXje1r"> <div id="ad1496-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1496" class="arcad ad-728x90"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1496",slotName:"kplc/web/news/national",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MMALD66DA5C7TLKARYDC6NEW4I"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:false})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="f0QQDmvCwXje1r"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.kplctv.com"> <div class="logo logo-slim"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 320 Division Street<br/>Lake Charles, LA 70601/70602<br/>(337) 439-9071 </p> <a class="call-to-action uppercase color-white" href="/about-us">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-on-desktop"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="https://publicfiles.fcc.gov/tv-profile/kplc" class="color-white">FCC Public File</a></li> <li><a href="mailto:bcourtney@kplctv.com" class="color-white">bcourtney@kplctv.com <br/> (337) 439-9071 ext. 507</a></li> <li><a href="http://webpubcontent.raycommedia.com/kplc/pdf/kplc-eeo.pdf" class="color-white">EEO</a></li> <li><a href="/story/12173010/how-to-file-a-closed-captioning-complaint/" class="color-white">Closed Captioning</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-on-desktop"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/KPLC7News" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/kplc7news" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl hidden visible-desktop"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="https://publicfiles.fcc.gov/tv-profile/kplc" class="color-white">FCC Public File</a></li> <li><a href="mailto:bcourtney@kplctv.com" class="color-white">bcourtney@kplctv.com <br/> (337) 439-9071 ext. 507</a></li> <li><a href="http://webpubcontent.raycommedia.com/kplc/pdf/kplc-eeo.pdf" class="color-white">EEO</a></li> <li><a href="/story/12173010/how-to-file-a-closed-captioning-complaint/" class="color-white">Closed Captioning</a></li> </ul> </div> <div class="hidden visible-desktop"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/KPLC7News" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/kplc7news" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rUmune2BwXje1r/render.js?v=11'></script>